Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 46

Thread: Multithreaded resource loading

  1. #21
    Co-Founder / PGD Elder WILL's Avatar
    Join Date
    Apr 2003
    Location
    Canada
    Posts
    6,108
    Blog Entries
    25
    Well I gat back from work and gave it a run. For the most part it runs just fine, graphics display and the sound clip plays too without any popup errors. However the one bug I found was that most of the faces were showing a block of glitchy and random static instead of their respective sprite. Here is a couple of screenies to show basically what it was doing.

    demo08_screen01.jpgdemo08_screen02.jpg

    Go ahead and send me an update or tweaked version if you like. I can be your 'real test run' on the current iMacs if you like.

    My system specs are:

    CPU: Intel Core i7 (Quad Core)
    GPU: ATI Radeon HD 4850
    Screen Res: 2560 x 1440 (27" screen)
    RAM: 4GB DDR3
    OS: Mac OS X 10.6.4
    Jason McMillen
    Pascal Game Development
    Co-Founder





  2. #22
    PGD Staff / News Reporter Stoney's Avatar
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    316
    Blog Entries
    4
    I've got the same problem WILL does when running the application on my MacBook Pro (Core 2 Duo 2.53 GHz, NVidia GeForce 9400 graphics card and 4 GB DDR3 RAM).
    Some sprites seem that they are not loaded correctly which seems to be always different sprites when re-running the application.
    Freeze Development | Elysion Game Framework | Twitter: @Stoney_FD
    Check out my new book: Irrlicht 1.7.1 Realtime 3D Engine Beginner's Guide (It's C++ flavored though)

    Programmer: A device for converting coffein into software.

  3. #23
    Co-Founder / PGD Elder WILL's Avatar
    Join Date
    Apr 2003
    Location
    Canada
    Posts
    6,108
    Blog Entries
    25
    Just a heads up, I ran it again (twice; ran it, Command-Q, ran it) just now out of curiosity and now ALL the images (including the glowy ZenGL image) except for the speaker and the x button and the label for the text shows some form of glitchy garble.
    Jason McMillen
    Pascal Game Development
    Co-Founder





  4. #24
    Tanks for tests. Seems I found the bug When the second thread loading texture to videocard(glTexImage2D) in first I'm tried to do glBindTexture. Now I changed something in my library, and it should work correctly(anyway now it work's correctly in my VirtualBox ). I will update demo soon.

  5. #25

  6. #26
    Co-Founder / PGD Elder WILL's Avatar
    Join Date
    Apr 2003
    Location
    Canada
    Posts
    6,108
    Blog Entries
    25
    Well that one worked a whole lot better. The x button doesn't play the song clip anymore but I do hear a 'click' sound when I do click on the window.

    All the images are fine now, but it does seem like you have any vsync turned on, which for OpenGL I don't think you can set in program anyhow. Am I right?

    Nice job!
    Jason McMillen
    Pascal Game Development
    Co-Founder





  7. #27
    Quote Originally Posted by WILL
    The x button doesn't play the song clip anymore but I do hear a 'click' sound when I do click on the window.
    Oh, I forgot to build my app statically with ogg libraries.

    Quote Originally Posted by WILL
    which for OpenGL I don't think you can set in program anyhow
    I can, but in this demo I didn't turn on it
    Last edited by Andru; 05-10-2010 at 05:28 AM.

  8. #28
    Co-Founder / PGD Elder WILL's Avatar
    Join Date
    Apr 2003
    Location
    Canada
    Posts
    6,108
    Blog Entries
    25
    So I guess this means you'll be making some Mac games pretty soon huh?
    Jason McMillen
    Pascal Game Development
    Co-Founder





  9. #29
    Quote Originally Posted by WILL
    So I guess this means you'll be making some Mac games pretty soon huh?
    Maybe, but for now I continue develop only the library(year ago one commercial game based on this library has been published for Macs, and new one waiting for release )
    Last edited by Andru; 05-10-2010 at 05:28 AM.

  10. #30
    Quote Originally Posted by Andru View Post
    I switch context only one time - for creating second context. After that all threads working without switching and waiting
    You need to switch the context. Otherwise your rendering commands will be send to the wrong threads if you want to handle drawing onscreen.

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •