The library for gba coding I released was a bit raw, so I have made a new (and more complete) port, translating libgba to pascal, and packaging it for freepascal. Now I have a little dilemma: should I follow pascal naming convention (making everything more understandable for pascal people) or should I let original libgba names (making easyer to understand existing c tutorials and code for gba)?
EG.: now I have code like
[pascal]// original libGBA naming convention
type bg_scroll = record
x: u16;
y: u16;
end;
...
function BG_PALETTE(m: integer): integer;
[/pascal]
but maybe should be nicer (and more readable)
[pascal]// pascal naming convention
type TBgScroll = record
x: u16;
y: u16;
end;
...
function BgPalette(m: integer): integer;
[/pascal]

Any suggestion will be very appreciated