PDA

View Full Version : Bug in view topics since last visit



Sly
10-01-2005, 12:39 PM
I got this bug in the search results for topics since last visit.
Click here for screenshot (http://www.users.on.net/~sly/images/pgdev-wronglink.jpg)

The last row lists 'Pop The Balloon' by savage with no replies and no views, but it lists the last post in that thread as by BlueCat on Nov 5, 2002 for a completely different thread.

WILL
11-01-2005, 03:12 AM
Ok sort of an odd bug, but I'll have a look at it.

Sly
13-01-2005, 10:02 PM
Got it happening again, but with the Cal3D news post. But this time there is an extra oddity. The list of new topics since last visit contains the posting about Cal3D three times. The first one works, the second says this thread contains no posts and the third says that BlueCat last posted to the thread in 2002.

Eriken
13-01-2005, 10:10 PM
looks like the "posts since last visit" adds a 3rd post on the news about 3DCal.. and the news-section only has 2.. Maybe it makes a mess when there are duplicate news-posts about the same thing?

Checking BlueCat's post was funny though, it's from the beginning of the DGDev forums.. hehe.
_____
Eriken

WILL
14-01-2005, 12:30 AM
There is a bug with the storing of ' and " characters in the Staff's News Report form where it'll read in the " character and it'll not take in the SQL string so it fails, however the rest of the script doesn't catch this and creates the topic anyways hence why you see duplicate topics of a news post.

I'm working to fix this problem(amoung many others) so expect a few glitches along the way.


I didn't really address the original problem, but I have to look at that seperately I have not played with this phpBB function at all before so I don't know much about it's code. How it may have been effected or if it is a bug in the original version of phpBB 2.0.6 it's self, I could not tell you at this point. It's going on the list, but it's a new one to me.

I'll post here once I descover something.

savage
14-01-2005, 06:33 AM
Hi WILL,
You can get MySQL to accept the " character when posting it by adding a \ before it. Then your post will be accepted, the only thing is that if you edit the post, you need to put the back slash back in again,

Sly
28-01-2005, 02:09 AM
Some more info on this bug. It only happens when the view count for a topic is zero. As soon as at least one person views the topic, the 'last post in topic' field is corrected.