PDA

View Full Version : View posts since last visit - BUG!



Clootie
13-12-2005, 06:36 PM
I'm using this convenient link: http://www.pascalgamedevelopment.com/forum_search.php?search_id=newposts
(too many forums exist to tack all new posts - this way it's mach easier :D ).

But starting this week (or previous) it's behaviour has changed: now it opens and lists messages correctly, but if I try to open link in new window I'm getting "No new posts since your last visit" page (and even no link to original topic). Currently "new posts" feature seems to work only if opening messages in current browser window.

Sorry, I have not tried to reproduce it (need new messages), but willing to provide enought info if requested. OS: Win XP SP2; Browser: IE 6.0.2900.2180 (SP2)

savage
13-12-2005, 08:41 PM
I think it's because once it has listed the posts since your last visit, it flags you as being up to date. Therefore when you open a new window, it's actually going back to the DB to find out if there are an new posts, but the DB has you flaged as being up to date. Not sure if WILL has changed anything in that respect though.

Clootie
13-12-2005, 10:22 PM
No, seems each time new window is opened with forum page -> "last visit" field in DB got updated. So even opening first topic in new windows shows expected result, but opening one more new window results in "no new posts available".

LP
14-12-2005, 12:22 AM
No, seems each time new window is opened with forum page -> "last visit" field in DB got updated. So even opening first topic in new windows shows expected result, but opening one more new window results in "no new posts available".
I think this is usually how the standard "new posts" feature work on most forums. On our forums at afterwarp.net (http://www.afterwarp.net) we use database tracking of unread posts, which although server extensive, is very accurate, but we don't use PhpBB, so I don't know what to suggest here.

Clootie
05-01-2006, 04:58 PM
Btw, it's fixed!
Thank you, WILL!

:D