PDA

View Full Version : Ineresting Opengl Problem



technomage
22-12-2005, 11:19 PM
Hi Everyone

I have an interesting problem and Iwas wondering if anyone else had seem this.

I have an opengl application it renders various meshes in a 3D star field. Now if I compile and run the application on the same machine everything works fine. However if I take that exe to another machine and run it without changes, I get an error message. If I recompile on that machine it works.... :? :?

I am totally confused. The fact that when it recompiles means it's very difficult to trace the bug. Anyone seen this before?

Dean :?

Robert Kosek
22-12-2005, 11:25 PM
Anyone seen this before?NEVER. That's a really odd bug, and I've done several GL apps myself and distributed them, but nothing has had problems like that.

technomage
23-12-2005, 07:55 AM
After allot of log file searching and adding new log entries I found the problem , it was a weird access violation when activating the texture, I have correctd it in my code, so it's not an opengl problem. But it was weird that the issue didn't appear on the machine that the app was compiled on....weird.. :D

going through log files was a bit of a blast from the past for me, that use to be the only way to debug applications before integrated debugging, I'd forgotten how teadious it is :wink:

Thanks for replying :D

Dean

Robert Kosek
23-12-2005, 02:42 PM
No problem.

I had an odd error once that didn't result in a crash, but totally screwed a texture up. Accidentally tried drawing a 24bit image as though it had an alpha channel and cut the visual size of the image roughly in half - while making a veritable kalidascope of colors. Took me a few seconds to straighten it out.

So what happened? I'd like to understand the gist of the cause just in case I encounter something like that myself.

technomage
23-12-2005, 07:19 PM
I was getting a nil referenced object when searching a Hashlist based on a string. This was then causing an exception to raise, but due to the exception handling in the app it wasn't crashing fully. As to why is didn't crash on one machine but did on another that is anyones guess.