PDA

View Full Version : Need some help with Omega.



Chesso
07-12-2006, 11:11 AM
Hello, I was unable to get UnDelphiX installed so I am giving Omega ago instead (all the other ones borked on me), this one seems promising so far.

But the documents don't give quite enough information, right now all I am interested in is drawing some text on the form (tied to the OmegaScreen Component, I am also using OmegaTimer).

I named OmegaScreen, OmegaDX and I can see drawing functions for rectangles and things but nothing to draw text? (UnDelphiX has it and uses a method of properties that i'm used to), but I can't see anything at all with Omega.

Firlefanz
07-12-2006, 11:25 AM
Have you taken a look at the samples? there are a lot up samples...

I can take a look when I am home in a few hours, but I bet there are samples using text...

There are two possibilities, OmegaFont or OmegaBMPfont.

Firle

NecroDOME
07-12-2006, 11:26 AM
Add omega primitives. With this you can draw lines n stuff. With OmegaFont (it was i think) you can print a bitmap font to the screen. You need to point the font and primitives to OmegaScreen.

I used omega in my 3D engine, but wrote my own font and GUI engine. I still use OmegaPrimitives.

Chesso
07-12-2006, 11:35 AM
I don't see any samples with the download I got, and the main site is a bunch of weird floral pictures :S.

The docs don't tell too much as of yet either and aren't up to date (it doesn't show all the components that are available).

Chesso
08-12-2006, 12:19 AM
Ok, I'm now using the BitMapFont component, but I can't see how to change average things like the type of font (like tahoma) and the size (a normal size setting), etc?

Firlefanz
08-12-2006, 06:25 AM
From my homepage:
Omega Help (older):
http://www.ericbehme.de/omega/Omega.html

Download latest, including 3 different versions,
two for DX8 and one for DX9 including samples:

http://www.ericbehme.de/phpBB2/viewtopic.php?t=132

Hope that helps a bit.

Firle

Chesso
08-12-2006, 07:03 AM
Hi, thanks, I have the old help with the package I got.

Things were going better until I tried to follow the help with using OemagSprite and OmegaImageList.

I loaded a GIF into an OmegaImageList component without any harp and set it all up, just like the help says, however I keep getting an error message "no omegaimagelist assigned to sprite".

Anything assignable, has been assigned and I can't find anything that reflect on this error.

All i'm aiming to do right now is draw an animation (as a sprite, for future use) on the omega screen along with the text already drawn in the OmegaTimer event when fired (I use OmegaSprite.Draw of course).

czar
08-12-2006, 07:29 AM
Maybe using the gif is your problem,

I suggest sticking to jpeg, bitmap or png

Chesso
08-12-2006, 08:52 AM
So i'll have to manually animate them..... why is there an ImageIndex property for the sprites....

Chesso
08-12-2006, 08:58 AM
Ok, so now i'm using a static PNG which seems fine.

Except for the fact that my text that I was drawing has now been transformed into that image, every character :S, wtf lol.

EDIT: Ok that seems fixed, odd that it happens automagically but oh well, so it looks like I can only use either the plain text or some image from the imagelist :S.