PDA

View Full Version : Upgrade to Lazarus 0.9.28/0.9.26 Issues



WILL
11-11-2009, 07:21 PM
Hey guys just wanted to point out a bit of an error that I noticed with the Lazarus 0.9.26 and 0.9.28 installers when installing/upgrading over an existing version.

.26 and .28 both use the newer FPC Compiler and because of this the file path to the executables are different. This causes a small(well depends on what you consider small I guess...) error when you try to compiler either a Lazarus Application or Program.

With .26 I found that I was unable to compile 'Applications' however trying to fix the error (having not yet discovered the true nature of the problem) I installed .28 on top of it. I then noticed that Nothing compiled at all at that point. It was then that I decided to look at the file paths for the compiler EXE and debugger, etc... I was lucky enough to notice that the file path indicated a different path.

IMPORTANT: If you run into this problem, you can solve it the same way I did. Uninstall Lazarus completely and reinstall the newer version from scratch. It might not be the smartest way to fix it, but it was the easiest.

paul_nicholls
11-11-2009, 08:29 PM
Hi WILL,
I always uninstall Lazarus prior to installing a later version (call me paranoid ;) ).

With that said, I DID have a path issue after installing 0.9.27 beta even after I uninstalled the 0.9.26 version...

I didn't have the same issue going to 0.9.28 and 0.9.28.2 though :)

cheers,
Paul