Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Problems installing Lazarus 0.9.30 in Ubuntu 11.04

  1. #1

    Problems installing Lazarus 0.9.30 in Ubuntu 11.04

    Hey all,
    I am having trouble installing Lazarus 0.9.30 in Ubuntu 10.04 (inside VirtualBox)...

    I downloaded fpc from here (latest .deb.tar version):
    http://sourceforge.net/projects/freepascal/files/

    I then unpacked it, and ran the install.sh script (
    Code:
    sudo ./install.sh
    )

    I then got Lazarus from here (latest .deb.tar version at top):
    http://sourceforge.net/projects/lazarus/files/

    I then unpacked it, and used dpkg to install the packages...but I get dependancy errors to do with fpc still!

    Here is the terminal output :
    Code:
    paulfnicholls@paulfnicholls-VirtualBox:~/Desktop/untitled folder$ sudo dpkg -i *.deb
    [sudo] password for paulfnicholls: 
    (Reading database ... 182115 files and directories currently installed.)
    Preparing to replace lazarus-0.9.30 0.9.30-0 (using lazarus-0.9.30_0.9.30-0_all.deb) ...
    Unpacking replacement lazarus-0.9.30 ...
    Preparing to replace lazarus-doc-0.9.30 0.9.30-0 (using lazarus-doc-0.9.30_0.9.30-0_all.deb) ...
    Unpacking replacement lazarus-doc-0.9.30 ...
    Preparing to replace lazarus-ide-0.9.30 0.9.30-0 (using lazarus-ide-0.9.30_0.9.30-0_i386.deb) ...
    Unpacking replacement lazarus-ide-0.9.30 ...
    Preparing to replace lazarus-ide-gtk2-0.9.30 0.9.30-0 (using lazarus-ide-gtk2-0.9.30_0.9.30-0_i386.deb) ...
    Unpacking replacement lazarus-ide-gtk2-0.9.30 ...
    Preparing to replace lazarus-ide-qt4-0.9.30 0.9.30-0 (using lazarus-ide-qt4-0.9.30_0.9.30-0_i386.deb) ...
    Unpacking replacement lazarus-ide-qt4-0.9.30 ...
    Preparing to replace lazarus-src-0.9.30 0.9.30-0 (using lazarus-src-0.9.30_0.9.30-0_all.deb) ...
    Unpacking replacement lazarus-src-0.9.30 ...
    Preparing to replace lcl-0.9.30 0.9.30-0 (using lcl-0.9.30_0.9.30-0_i386.deb) ...
    Unpacking replacement lcl-0.9.30 ...
    Preparing to replace lcl-gtk2-0.9.30 0.9.30-0 (using lcl-gtk2-0.9.30_0.9.30-0_i386.deb) ...
    Unpacking replacement lcl-gtk2-0.9.30 ...
    Preparing to replace lcl-nogui-0.9.30 0.9.30-0 (using lcl-nogui-0.9.30_0.9.30-0_i386.deb) ...
    Unpacking replacement lcl-nogui-0.9.30 ...
    Preparing to replace lcl-qt4-0.9.30 0.9.30-0 (using lcl-qt4-0.9.30_0.9.30-0_i386.deb) ...
    Unpacking replacement lcl-qt4-0.9.30 ...
    Preparing to replace lcl-units-0.9.30 0.9.30-0 (using lcl-units-0.9.30_0.9.30-0_i386.deb) ...
    Unpacking replacement lcl-units-0.9.30 ...
    Preparing to replace lcl-utils-0.9.30 0.9.30-0 (using lcl-utils-0.9.30_0.9.30-0_i386.deb) ...
    Unpacking replacement lcl-utils-0.9.30 ...
    Setting up lazarus-doc-0.9.30 (0.9.30-0) ...
    dpkg: dependency problems prevent configuration of lazarus-ide-0.9.30:
     lazarus-ide-0.9.30 depends on fp-compiler; however:
      Package fp-compiler is not installed.
    dpkg: error processing lazarus-ide-0.9.30 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of lazarus-ide-gtk2-0.9.30:
     lazarus-ide-gtk2-0.9.30 depends on lazarus-ide-0.9.30; however:
      Package lazarus-ide-0.9.30 is not configured yet.
    dpkg: error processing lazarus-ide-gtk2-0.9.30 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of lazarus-ide-qt4-0.9.30:
     lazarus-ide-qt4-0.9.30 depends on lazarus-ide-0.9.30; however:
      Package lazarus-ide-0.9.30 is not configured yet.
     lazarus-ide-qt4-0.9.30 depends on lazarus-ide-gtk-0.9.30; however:
      Package lazarus-ide-gtk-0.9.30 is not installed.
      Package lazarus-ide-gtk2-0.9.30 which provides lazarus-ide-gtk-0.9.30 is not configured yet.
    dpkg: error processing lazarus-ide-qt4-0.9.30 (--install):
     dependency problems - leaving unconfigured
    Setting up lazarus-src-0.9.30 (0.9.30-0) ...
    dpkg: dependency problems prevent configuration of lcl-gtk2-0.9.30:
     lcl-gtk2-0.9.30 depends on fpc-abi-2.4.2; however:
      Package fpc-abi-2.4.2 is not installed.
     lcl-gtk2-0.9.30 depends on fp-units-rtl; however:
      Package fp-units-rtl is not installed.
     lcl-gtk2-0.9.30 depends on fp-units-base; however:
      Package fp-units-base is not installed.
     lcl-gtk2-0.9.30 depends on fp-units-fcl; however:
      Package fp-units-fcl is not installed.
     lcl-gtk2-0.9.30 depends on fp-units-gtk2; however:
      Package fp-units-gtk2 is not installed.
    dpkg: error processing lcl-gtk2-0.9.30 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of lcl-nogui-0.9.30:
     lcl-nogui-0.9.30 depends on fpc-abi-2.4.2; however:
      Package fpc-abi-2.4.2 is not installed.
     lcl-nogui-0.9.30 depends on fp-units-rtl; however:
      Package fp-units-rtl is not installed.
     lcl-nogui-0.9.30 depends on fp-units-base; however:
      Package fp-units-base is not installed.
     lcl-nogui-0.9.30 depends on fp-units-fcl; however:
      Package fp-units-fcl is not installed.
    dpkg: error processing lcl-nogui-0.9.30 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of lcl-qt4-0.9.30:
     lcl-qt4-0.9.30 depends on fpc-abi-2.4.2; however:
      Package fpc-abi-2.4.2 is not installed.
     lcl-qt4-0.9.30 depends on fp-units-rtl; however:
      Package fp-units-rtl is not installed.
     lcl-qt4-0.9.30 depends on fp-units-base; however:
      Package fp-units-base is not installed.
     lcl-qt4-0.9.30 depends on fp-units-fcl; however:
      Package fp-units-fcl is not installed.
     lcl-qt4-0.9.30 depends on libqt4pas-dev; however:
      Package libqt4pas-dev is not installed.
    dpkg: error processing lcl-qt4-0.9.30 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of lcl-units-0.9.30:
     lcl-units-0.9.30 depends on fpc-abi-2.4.2; however:
      Package fpc-abi-2.4.2 is not installed.
     lcl-units-0.9.30 depends on lcl-gtk2-0.9.30 (= 0.9.30-0) | lcl-gtk-0.9.30 (= 0.9.30-0) | lcl-qt-0.9.30 (= 0.9.30-0); however:
      Package lcl-gtk2-0.9.30 is not configured yet.
      Package lcl-gtk-0.9.30 is not installed.
      Package lcl-qt-0.9.30 is not installed.
    dpkg: error processing lcl-units-0.9.30 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of lcl-utils-0.9.30:
     lcl-utils-0.9.30 depends on fp-compiler; however:
      Package fp-compiler is not installed.
    dpkg: error processing lcl-utils-0.9.30 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of lazarus-0.9.30:
     lazarus-0.9.30 depends on lazarus-ide-0.9.30 (>= 0.9.30-0); however:
      Package lazarus-ide-0.9.30 is not configured yet.
    dpkg: error processing lazarus-0.9.30 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of lcl-0.9.30:
     lcl-0.9.30 depends on lcl-units-0.9.30; however:
      Package lcl-units-0.9.30 is not configured yet.
     lcl-0.9.30 depends on lcl-utils-0.9.30; however:
      Package lcl-utils-0.9.30 is not configured yet.
    dpkg: error processing lcl-0.9.30 (--install):
     dependency problems - leaving unconfigured
    Processing triggers for doc-base ...
    Processing 1 changed doc-base file(s)...
    Registering documents with scrollkeeper...
    Processing triggers for bamfdaemon ...
    Rebuilding /usr/share/applications/bamf.index...
    Processing triggers for desktop-file-utils ...
    Processing triggers for python-gmenu ...
    Rebuilding /usr/share/applications/desktop.en_AU.utf8.cache...
    Processing triggers for man-db ...
    Processing triggers for python-support ...
    Errors were encountered while processing:
     lazarus-ide-0.9.30
     lazarus-ide-gtk2-0.9.30
     lazarus-ide-qt4-0.9.30
     lcl-gtk2-0.9.30
     lcl-nogui-0.9.30
     lcl-qt4-0.9.30
     lcl-units-0.9.30
     lcl-utils-0.9.30
     lazarus-0.9.30
     lcl-0.9.30
    paulfnicholls@paulfnicholls-VirtualBox:~/Desktop/untitled folder$
    Any ideas? Windows is much easier than this!!!

    cheers,
    Paul

  2. #2
    Any Linux/Ubuntu gurus out there who can help?!?

  3. #3
    I don't have a working Lazarus on my Ubuntu at the moment, but once it used to... i brokes it

    Have you tried simply from Synaptic packet handler? You can set it to list external sources or something if fpc doesn't list by default.

    What i guess should be done is a perfect clean up first.

    Also the way some people install it, is extracting them in your /home/ or something manually. That way the files are all in 1 place like in Windows and you may have easier time with it. Ubuntu is using so many different folders in the system that it makes head hurt.
    Last edited by User137; 02-09-2011 at 06:29 AM.

  4. #4
    When I did a search for Lazarus in the Synaptic package handler, it only had the 0.9.28.2 version (I think), not the 0.9.30 version - but this might not matter and I should just look for freepascal first using that and see what I can find (2.4.x hopefully).

    If I can find freepascal using the package manager, then this might solve my dependency issue

    EDIT: apparently I need to install the binary version AND source version of freepascal in Linux for Lazarus to work! What a pain in the arse

    Wish me luck!!

    cheers,
    Paul
    Last edited by paul_nicholls; 02-09-2011 at 06:57 AM.

  5. #5
    ok, the only freepascal I found with the package manager was the alternate IDE to Lazarus (can't recall the name now)...

    cheers,
    Paul

  6. #6
    dang and blast!

    I finally got Lazarus installed only to find I can't compile a new bare-bones GUI project

    Code:
    /usr/bin/ld: warning: link.res contains output sections; did you forget -T?
    /usr/bin/ld: cannot find -lX11
    /usr/bin/ld: cannot find -lgdk_pixbuf-2.0
    /usr/bin/ld: cannot find -lgtk-x11-2.0
    /usr/bin/ld: cannot find -lgdk-x11-2.0
    /usr/bin/ld: cannot find -lgobject-2.0
    /usr/bin/ld: cannot find -lglib-2.0
    /usr/bin/ld: cannot find -lgthread-2.0
    /usr/bin/ld: cannot find -lgmodule-2.0
    /usr/bin/ld: cannot find -lpango-1.0
    /usr/bin/ld: cannot find -latk-1.0
    /usr/bin/ld: cannot find -lcairo
    project1.lpr(19,1) Error: Error while linking
    project1.lpr(19,1) Fatal: There were 1 errors compiling module, stopping
    This is the path to fpc source in the Environment/Options in the IDE:

    Code:
    /usr/share/fpcsrc/2.4.2/
    cheers,
    Paul

  7. #7
    Hey all,
    since I was using Ubuntu in a virtual machine, it was rather slow. So I have bit the bullet so to speak, deleted a bunch of stuff on my laptop to make room, and now I have installed Ubuntu as a separate program (not needing a separate partition - is supposed to have slightly lower disc access performance, but it seems quite fast for me).

    This means I can boot into Vista or Ubuntu now (yay!)

    I am now starting again with my Ubuntu software including Lazarus. I have now found this page:
    http://wiki.lazarus.freepascal.org/I...11.04_or_later

    and I seem to be having more luck with this way of installing Lazarus (touch wood...and trying not to jinx me! haha)

    Hopefully this time will be the charm!

    (Written from Ubuntu, Google Chrome)...

    cheers,
    Paul

  8. #8
    Woo Hoo!! it works!!

    Now all I need to do is figure out how to dock the messages + source + menu windows together - I did do this in a windows version of Lazarus but I can't recall how now LOL

    EDIT: ok, I went here:
    http://wiki.lazarus.freepascal.org/Anchor_Docking

    See this part of the text:

    There is an IDE package which makes the Lazarus IDE dockable. It is called anchordockingdsgn.lpk. Make sure you only install one docking package. Do not install the easydockmgr at the same time!
    I hope this helps somone else!

    cheers,
    Paul
    Last edited by paul_nicholls; 03-09-2011 at 01:03 PM.

  9. #9
    PGD Staff code_glitch's Avatar
    Join Date
    Oct 2009
    Location
    UK (England, the bigger bit)
    Posts
    933
    Blog Entries
    45
    You know you could just have done a
    Code:
    sudo apt-get install lazarus
    Ubuntu 11.04 is usually quite good for keeping on track and its literally as easy as 123
    I once tried to change the world. But they wouldn't give me the source code. Damned evil cunning.

  10. #10
    Quote Originally Posted by code_glitch View Post
    You know you could just have done a
    Code:
    sudo apt-get install lazarus
    Ubuntu 11.04 is usually quite good for keeping on track and its literally as easy as 123
    Sorry, but that would have gotten me 0.9.28.2 (I think), not the latest 0.9.30+ versions...

    At least with the couple of lines of script, I was able to get the 0.9.30 version...almost as easy

    cheers,
    Paul

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comodo SSL