Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33

Thread: Asphyre Sphinx 3.0.0 has been released.

  1. #21
    Quote Originally Posted by AirPas View Post
    finally Asphyre for lazarus , how about the performance i mean between lazarus and delphi which one produce fast code ! , in my machine delphi is faster but just 4 or 5% iam sure with FPC 2.7.1 the result would be much faster , due to the new optimization O4.
    Compiled examples with optimization enabled have very similar performance. From my perspective, both compilers optimize the code pretty well.

    Quote Originally Posted by AirPas View Post
    in lazarus it would be better if you define the paths like so :
    ..\..\..\..\Source;..\..\..\..\Source\Providers;.. \..\..\..\Source\Headers;..\..\..\..\Source\GUI
    Yes, I've updated all paths to be like this, you can update from the trunk. Later today I'll publish another Asphyre version.

  2. #22

    Post Asphyre Sphinx 3.0.1 update is now available (DirectX 11 and 3D features).

    As the title says, Asphyre Sphinx has been updated to version 3.0.1.

    In this update, DirectX 11 support has been added, which uses advanced fallback mechanisms for lower feature levels such as Direct3D 10.1, Direct3D 10.0 and even legacy Direct3D 9, in addition to Windows WARP highly optimized software device. This means that Asphyre powered applications using DirectX 11 will run on any system where DirectX 11 is installed no matter whether it has hardware support or not. This provider works with Embarcadero Delphi (either XE 2+ or any version from 2007 and upwards) and FreePascal/Lazarus. No external DLLs are required for this provider to work.

    Also, 3D features that were available in earlier releases are now part of Asphyre Sphinx 3 too.

    For more information and download links, you can visit official Asphyre Sphinx 3 web page. Alternatively, you can update your repository from the trunk.

  3. #23
    Hi Lifepower, I get the following error when trying to compile the examples. Using Delphi 2010.

    [DCC Error] MediaUtils.pas(319): E2254 Overloaded procedure 'ParseFloat' must be marked with the 'overload' directive
    [DCC Error] MediaUtils.pas(121): E2065 Unsatisfied forward or external declaration: 'ParseFloat'
    [DCC Fatal Error] AsphyreImages.pas(400): F2063 Could not compile used unit 'MediaUtils.pas'

    Any ideas?
    Wake up from the dream and live your life to the full

  4. #24
    Wizard, unless you have conflict with some older Asphyre package, it seems more like a compiler bug, as you can see that the mentioned procedure does have "overload" flag. Could you try to comment one of these functions and remove "overload" parameter?

    The package was tested in Delphi 2007 and XE 2, so there is no reason why it shouldn't work with Delphi 2010.

  5. #25
    By the way, Asphyre Sphinx 3 works with Delphi XE 3.

    Also, I've ported some lousy software rasterizer for Asphyre Sphinx 3, for those who want some fun with it.

  6. #26

    Post Asphyre Sphinx 3.0.2 (DX11, DX9, Linux) and Tulip UI

    It's time for another update. Asphyre Sphinx 3.0.2 has been released, which resolves minor aesthetic issues in DirectX 11 provider, fixes sleep recovery in DirectX 9 Ex (vista) provider and resolves minor timing problem. In addition, this release now features native Linux OpenGL provider that no longer depends on other packages thanks to code kindly provided by Andru, the developer of ZenGL.

    Also, an alternative UI with its accompanying open-source WYSIWYG editor is now available called Tulip User Interface Library, kindly provided by Marcos Gomes. It uses latest language features of Delphi XE 2 and XE 3 and allows creating of a very good looking interfaces, while being also very easy to use.
    Last edited by LP; 09-09-2012 at 09:27 PM. Reason: Typo in author name, sorry. :(

  7. #27
    Okay, I just tried it with my Xubuntu 12.04 64bit. Version 3.0.1 worked fine. This is what I receive for all examples on the terminal (even after newly compiled):
    The program 'Shapes' received an X Window System error.
    This probably reflects a bug in the program.
    The error was 'BadMatch (invalid parameter attributes)'.
    (Details: serial 418 error_code 8 request_code 135 minor_code 5)
    (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    backtrace from your debugger if you break on the gdk_x_error() function.)
    None of the examples works now for me. I thought you might need to know this.
    Best regards,

  8. #28
    Seems this is a problem of NVIDIA blob(currently your videocard is GeForce 8600GT?) and initializing OpenGL context with custom options, when you use already created window with unknown visualinfo. Try to open XGLDevices.pas and replace line 168 with this one:
    here main change is GLX_ALPHA_SIZE, 0
    Last edited by Andru; 11-09-2012 at 07:42 PM.

  9. #29
    Thanks Andru, that helped and now it works.
    Best regards,

  10. #30
    Thanks for reporting this, I'm going to change the source code to remove the alpha attribute.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts