Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Problem compiling under SuSE9.1

  1. #1

    Problem compiling under SuSE9.1

    Here's the environment.

    SuSE9.1 Pretty much a fresh install
    Kylix 1

    After much faffing around trying to get the damned thing to even run, in the end having to supply an environment variable export D_ASSUME_KERNEL=2.4.1
    which I tacked onto the start of my startkylix script...
    OK it, then went through it's Generating Font matrix which was taking forever, cancelling the window seemed to work.

    Then it came to compiling... and I got some message about

    [Error] Bad file format: ''
    [Error] Bad file format: ''

    Looking on some german forum they suggested editing my .bashrc file and adding an alias
    alias startdelphi='export LD_ASSUME_KERNEL=2.4.1 && startdelphi'

    This has made no difference so far..

    Has anyone else had this trouble or am I just cursed?

  2. #2

    Problem compiling under SuSE9.1

    Hi Jason,
    great to see you on here . My understanding is that Suse 9.1 uses the 2.6 Linux kernel.

    Have you tried the following on the command line...
    export LD_ASSUME_KERNEL=2.4.0

    or alternatively, you could add the "export LD_ASSUME_KERNEL=2.4.0" to the top of the startdelphi script..

    Some instructions I found on google groups were...

    2. Edited the script files to include : export LD_ASSUME_KERNEL=2.4.0

    At this point it still didn't work, but got a different error message
    about relocation of not being linked in

    Checked my /kylix/bin directory and both files were linked to original
    filesin /lib/tls.
    Did a search for libpthread and libc and found they also existed in both
    /lib and /lib/i686. Decided to destroy both links in /kylix/bin and
    linked the libpthread and libc files from /lib/i686 to /kylix/bin.

    At this point ran the startdelphi script and the Kylix 3 IDE loaded.
    I hope this helps in some way. I use Mandrake 10 and do not remember having this problem.
    <br /><br />There are a lot of people who are dead while they are still alive. I want to be alive until the day I die.<br />-= Paulo Coelho =-

  3. #3

    Problem compiling under SuSE9.1

    I've just tried the export

    export LD_ASSUME_KERNEL=2.4.0
    But I get the same error.

    I originally had
    export LD_ASSUME_KERNEL=2.4.1
    But it didn't work.

    I still have my old Linux environment intact, so it's not a complete loss, but I'd really like to be able to use Kylix under SuSE9.1

    For the record, I've placed the export command in both the startkylix script and the .bascrc file. But still no joy.

  4. #4

    Problem compiling under SuSE9.1

    what about the tip about
    libpthread and libc
    In the previous post refering to stray symbolic links. Did you try that?
    <br /><br />There are a lot of people who are dead while they are still alive. I want to be alive until the day I die.<br />-= Paulo Coelho =-

  5. #5

    Problem compiling under SuSE9.1

    Ah, I didn't notice that part

    I'll give that a shot...

  6. #6

    Problem compiling under SuSE9.1


    Those files didn't even exist in my Kylix/bin directory. This is Kylix1

    I did have 2 versions of those .so files though in /lib/i686 and /lib, so I linked to the i686 versions and put the links in the kylix/bin directory.

    But it's made no difference.

  7. #7

    Problem compiling under SuSE9.1

    Hi Jason,
    Merry Christmas!

    I don't know if you managed to get it working, but I thought I would post my "startdelphi" contents...
    LC_ALL_IS_C1="The LC_ALL environment variable is set to C.  Kylix cannot start with this setting."
    LC_ALL_IS_C2="Defaulting LC_ALL to"
    if &#91; -z "$LANG" &#93;; then
       export LANG
    if &#91; "$LC_ALL" = "C" &#93;; then
       echo "$LC_ALL_IS_C1"
       echo "$LC_ALL_IS_C2 $KYDEF_LOCALE."
       export LC_ALL
    export LD_ASSUME_KERNEL=2.4.1
    source /home/dominique/kylix3/bin/kylixpath /home/dominique/kylix3 >/dev/null
    /home/dominique/kylix3/bin/delphi $*
    I am using Mandrake 10.1, but that should not make any difference. I am not sure if the export before the source / command is necessary.

    Anyway I hope this helps somehow,
    <br /><br />There are a lot of people who are dead while they are still alive. I want to be alive until the day I die.<br />-= Paulo Coelho =-

  8. #8

    Problem compiling under SuSE9.1

    Sorry mate,

    No joy. Tried pasting your startdelphi code into my StartKylix script, altering where required, paths & stuff.

    Same error. I think it's just a problem between SuSE and Kylix.

    So I think I'm going to give up on this.
    Can someone point me in the right direction for getting a different IDE and FreePascal working? I have no clue where to start and I could do with getting back on my feet as soon as possible

  9. #9

    Problem compiling under SuSE9.1

    Hi Jason,
    Sorry to hear that. Have you tried Lazarus ( ), I have not tried it lately, but I hear the latest release it relatively stable, though not perfect.

    Other alternative IDEs are...
    MiniPascal -
    DevPascal -

    Of these however, I think Lazarus is the only one that works on Win32, Linux and MacOS X.

    Either way I hope it helps.
    <br /><br />There are a lot of people who are dead while they are still alive. I want to be alive until the day I die.<br />-= Paulo Coelho =-

  10. #10

    Problem compiling under SuSE9.1

    Cheers mate,

    I got Lazarus and I'm very impressed. All of the RPM's worked on my SuSE box (with a little complaining, but nothing serious)

    Now I'm just trying to get stuff to compile. It meant I needed to get the latest Jedi-SDL with Cross compiler support built in. Just having troubles with my stuff now.

    Am I right in thinking that there's no intellisence with Lazarus?

    If I can get this working, Bye Bye Kylix.

Page 1 of 2 12 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts