Results 1 to 5 of 5

Thread: Ineresting Opengl Problem

  1. #1

    Ineresting Opengl Problem

    Hi Everyone

    I have an interesting problem and Iwas wondering if anyone else had seem this.

    I have an opengl application it renders various meshes in a 3D star field. Now if I compile and run the application on the same machine everything works fine. However if I take that exe to another machine and run it without changes, I get an error message. If I recompile on that machine it works.... :? :?

    I am totally confused. The fact that when it recompiles means it's very difficult to trace the bug. Anyone seen this before?

    Dean :?
    <A HREF="http://www.myhpf.co.uk/banner.asp?friend=139328">
    <br /><IMG SRC="http://www.myhpf.co.uk/banners/60x468.gif" BORDER="0">
    <br /></A>

  2. #2

    Ineresting Opengl Problem

    Anyone seen this before?
    NEVER. That's a really odd bug, and I've done several GL apps myself and distributed them, but nothing has had problems like that.

  3. #3

    Ineresting Opengl Problem

    After allot of log file searching and adding new log entries I found the problem , it was a weird access violation when activating the texture, I have correctd it in my code, so it's not an opengl problem. But it was weird that the issue didn't appear on the machine that the app was compiled on....weird..

    going through log files was a bit of a blast from the past for me, that use to be the only way to debug applications before integrated debugging, I'd forgotten how teadious it is

    Thanks for replying

    Dean
    <A HREF="http://www.myhpf.co.uk/banner.asp?friend=139328">
    <br /><IMG SRC="http://www.myhpf.co.uk/banners/60x468.gif" BORDER="0">
    <br /></A>

  4. #4

    Ineresting Opengl Problem

    No problem.

    I had an odd error once that didn't result in a crash, but totally screwed a texture up. Accidentally tried drawing a 24bit image as though it had an alpha channel and cut the visual size of the image roughly in half - while making a veritable kalidascope of colors. Took me a few seconds to straighten it out.

    So what happened? I'd like to understand the gist of the cause just in case I encounter something like that myself.

  5. #5

    Ineresting Opengl Problem

    I was getting a nil referenced object when searching a Hashlist based on a string. This was then causing an exception to raise, but due to the exception handling in the app it wasn't crashing fully. As to why is didn't crash on one machine but did on another that is anyones guess.
    <A HREF="http://www.myhpf.co.uk/banner.asp?friend=139328">
    <br /><IMG SRC="http://www.myhpf.co.uk/banners/60x468.gif" BORDER="0">
    <br /></A>

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comodo SSL