Results 1 to 2 of 2

Thread: Aspyhre Sphinx 4.0 Open GL Cliprect Problem

  1. #1

    Aspyhre Sphinx 4.0 Open GL Cliprect Problem

    Hi there.

    I am currently running in a problem with gamecanvas.cliprect while using the OpenGL provider.

    Once i set a cliprect all images disappear. It works as it should when i change it to DirectX. So i took a look into it and found in apshyre.canvas.gl2 :

    Code:
    procedure TGLCanvas.SetViewport(x, y, Width, Height: Integer);
    var
     ViewPos: Integer;
    begin
     ResetScene();
    
     ViewPos:= (ViewportRect.Bottom - ViewportRect.Top) - (y + Height);
    
     glScissor(x, Viewpos, Width, Height);
     ClippingRect:= Bounds(x, y, Width, Height);
    end;
    I have to admit i have no idea what this ViewPos is for, but it was the only value that was far away from my cliprect setting so i just tried to change it to y and at first this seemed to work. Cliprect was working as it should, but later i noticed some strange behaviour. With certain cliprect settings images disappear again although they should still be visible. Again, it works as it should with DirectX.

    Any idea how i can fix that? Inb4 Thank you.

  2. #2
    I worked around the problem by simply not using any cliprects.. a little inconvienient but it will work.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comodo SSL