Results 1 to 7 of 7

Thread: CodeGear+Vista x64+OpenGL

  1. #1

    CodeGear+Vista x64+OpenGL

    I have rewrited my very old 3d engine to new caled Final3D, but before month I changed PC to new

    (C2D X6800, 4GB RAM, NV8800GTX, Vista x64 Ultimate)

    now i have big problem because CodeGear compile engine OK, but after run show error: acces violation nvogl32.dll from adress 00000000. I tried engine in XP SP2 compatibility mode and problem still same. I use dglOpenGL.pas header.

    PS.: Problem is only if I use GLSL shaders in a scene.

    SRC/BIN -> http://a3d.intelligentdevelopment.sk...ngine_2006.zip

    [A]

    Shader debug/test scene:

    Open default.cfg and set:

    cg_level_name : tbn_test.level

    [b]

    Newton debug/test scene:

    Open default.cfg and set:

    cg_level_name : npx_test.level



    Any experiens with this problem?[/url]
    C2D X6800, 4GBRAM, NV8800GTX, Vista x64 Ultimate

  2. #2

    CodeGear+Vista x64+OpenGL

    Nice to see you back

    I don't have vista but I tested your demo on my XP machine (Athlon 3800+, 1 Gig Ram, NV 7800 GT) And it all worked fine.

    I can't see anything wrong with your shaders either, but I'm not an expert (yet )

    The error sounds like a bug in the nVidia Vista Drivers though, rather than anything in your program.
    <A HREF="http://www.myhpf.co.uk/banner.asp?friend=139328">
    <br /><IMG SRC="http://www.myhpf.co.uk/banners/60x468.gif" BORDER="0">
    <br /></A>

  3. #3

    CodeGear+Vista x64+OpenGL

    Hmm. It's maybe true, that is problem in DX Vista GL wrapper
    C2D X6800, 4GBRAM, NV8800GTX, Vista x64 Ultimate

  4. #4

    CodeGear+Vista x64+OpenGL

    Hi andygfx,
    Welcome back!

    Have you seen the work that technomage did on porting A3D to JEDI-SDL?
    <br /><br />There are a lot of people who are dead while they are still alive. I want to be alive until the day I die.<br />-= Paulo Coelho =-

  5. #5

    CodeGear+Vista x64+OpenGL

    When I run the demo on my Windows XP box, I get a Range Check Error .
    <br /><br />There are a lot of people who are dead while they are still alive. I want to be alive until the day I die.<br />-= Paulo Coelho =-

  6. #6

    CodeGear+Vista x64+OpenGL

    I play with this idea, but for now i must find solution for my problem, because i yesterday tried install Delphi7 under WinXP+SP2 (winxp as dualboot) and after compiling now i have same problem unded WinXP. It's crazy. First error was -> missing msvcr70.dll and after update this one, error message was: nvoglnt.dll acces violation.

    sum errors:

    Vista x64 = msvcr71.dll and nvogl32.dll
    WinXP x32 = msvcr70.dll and nvoglnt.dll

    other possible problems with old:

    DevIL lib or Newton

    Looks like compatibility problem with DOT NET 1.1 / 2.0 and NV drivers



    I'm not a expert on SDL, but maybe this is one way to fix all problems.
    C2D X6800, 4GBRAM, NV8800GTX, Vista x64 Ultimate

  7. #7

    CodeGear+Vista x64+OpenGL

    I maybe found problem with my engine.
    C2D X6800, 4GBRAM, NV8800GTX, Vista x64 Ultimate

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comodo SSL