Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: OpenGL 3.x cube problem

  1. #11

    Re: OpenGL 3.x cube problem

    Found the real problem :-)
    In the resizewindow part i already 'publish' the projectionlocation matrix, but the location is not known yet and default being 0. But when requested its location becomes 1 resulting that it is overwritten by the modelview matrix that gets location 0. So as a workaround i calculate the matrix as before but only 'publish' it in the init part.
    And next the cube showed up :-)

    Final source: http://www.noeska.net/downloads/Ogl3Cube4.zip
    http://3das.noeska.com - create adventure games without programming

  2. #12

    Re: OpenGL 3.x cube problem

    Finished some more examples from http://nopper.tv/opengl_3_2.html

    Here are the examples in delphi: http://www.noeska.net/ogl3xexamples.zip

    Bugs:
    - i dont trust the cubemapping example, or it could be the tga reader flipping textures.
    - the particle system does not work with the the shape textures due to in the fragment shader gl_PointCoord is always 0. But instead it shows red squares as points.

    @Luuk van Venrooij: What is the url of your website, so i can have a look at your ogl3 progress.
    http://3das.noeska.com - create adventure games without programming

  3. #13

    Re: OpenGL 3.x cube problem

    Today i was able to test the particle system on nvidia hardware and there it works.
    http://3das.noeska.com - create adventure games without programming

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comodo SSL