Yeah, I'd just like to add that it's always best practice to avoid reusing ANY keywords or common language functions or you could end up having some crazy logic issues and errors in your programs. I try to think of nice alternatives myself.

For example lets say you have a record that stores what "type" of object they are, well what do you call that variable to hold that value? Type would be terrible and would most likely cause an error preventing it from compiling. Instead I would try using "kind" (real life example!) as it does not conflict with the keyword type used to define different variable types.

Oh and feel free to use the code button to post your code right in your post. It should work as long as it's not too long (long as in reallllllly long) User137's post is a good example of posting code of a decent size length.